# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^('''\n?(?:.*?)(?:\n.*)*)(?!'''\n?)$"
test_str = ("'''\n"
"IF OPENING DELIMITER IS NOT MATCHED,\n"
"ADD CLOSING DELIMITER TO MATCH\n"
"sad\n"
"fsd\n"
"f\n"
"sdaf\n"
"sdaf\n"
"sdf\n"
"sdaf\n"
"sdf\n"
"dsfa\n"
"sdf\n"
"aasdf\n"
"dsf")
subst = "$1\\n'''"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.