const regex = /^('''\n?(?:.*?)(?:\n.*)*)(?!'''\n?)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\'\'\'\\n?(?:.*?)(?:\\n.*)*)(?!\'\'\'\\n?)$', 'g')
const str = `'''
IF OPENING DELIMITER IS NOT MATCHED,
ADD CLOSING DELIMITER TO MATCH
sad
fsd
f
sdaf
sdaf
sdf
sdaf
sdf
dsfa
sdf
aasdf
dsf`;
const subst = `$1\n'''`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);