const regex = /(\G(?!^)|<h\d+\s+id=")([^"]*?)([üöä])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\G(?!^)|<h\\d+\\s+id=")([^"]*?)([üöä])', 'gm')
const str = `<h1 id="anwendungsfälle-und--funktionen">Anwendungsfälle und -funktionen</h1>
<h1 id="öl">Öl</h1>`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);