import Foundation
let pattern = #"(\G(?!^)|<h\d+\s+id=")([^"]*?)([üöä])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<h1 id="anwendungsfälle-und--funktionen">Anwendungsfälle und -funktionen</h1>
<h1 id="öl">Öl</h1>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)