re = /(\G(?!^)|<h\d+\s+id=")([^"]*?)([üöä])/m
str = '<h1 id="anwendungsfälle-und--funktionen">Anwendungsfälle und -funktionen</h1>
<h1 id="öl">Öl</h1>'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result