using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]+\.?[0-9,]* ?(?:UI|IU|MCG|G|I.U|I.U.|MG|ML|GM)(?:\/?[0-9]+\.?[0-9]* ?(?:UI|IU|MCG|G|I.U|I.U.|MG|ML|GM))?";
string input = @"DEXTROSE ANHYDRROUS 5.00 G/5G SODIUM CHLORIDE 0.45G
sfasefsafes234.2,34 ML ,2 ML
0.5 MG/234ML
0.5MG23
0.5MCG
0234.2342 MCG
500,505,55 MCG";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}