$re = '/[0-9]+\.?[0-9,]* ?(?:UI|IU|MCG|G|I.U|I.U.|MG|ML|GM)(?:\/?[0-9]+\.?[0-9]* ?(?:UI|IU|MCG|G|I.U|I.U.|MG|ML|GM))?/m';
$str = 'DEXTROSE ANHYDRROUS 5.00 G/5G SODIUM CHLORIDE 0.45G
sfasefsafes234.2,34 ML ,2 ML
0.5 MG/234ML
0.5MG23
0.5MCG
0234.2342 MCG
500,505,55 MCG';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);