package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]+\.?[0-9,]* ?(?:UI|IU|MCG|G|I.U|I.U.|MG|ML|GM)(?:\/?[0-9]+\.?[0-9]* ?(?:UI|IU|MCG|G|I.U|I.U.|MG|ML|GM))?`)
var str = `DEXTROSE ANHYDRROUS 5.00 G/5G SODIUM CHLORIDE 0.45G
sfasefsafes234.2,34 ML ,2 ML
0.5 MG/234ML
0.5MG23
0.5MCG
0234.2342 MCG
500,505,55 MCG`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}