import re
regex = re.compile(r"[0-9]+\.?[0-9,]* ?(?:UI|IU|MCG|G|I.U|I.U.|MG|ML|GM)(?:\/?[0-9]+\.?[0-9]* ?(?:UI|IU|MCG|G|I.U|I.U.|MG|ML|GM))?", flags=re.MULTILINE)
test_str = ("DEXTROSE ANHYDRROUS 5.00 G/5G SODIUM CHLORIDE 0.45G\n"
"sfasefsafes234.2,34 ML ,2 ML\n"
"0.5 MG/234ML\n"
"0.5MG23\n"
"0.5MCG\n"
"0234.2342 MCG\n"
"500,505,55 MCG")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")