#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Z]([a-z]+). [A-z]+"
Local $sString = "Dr. Doctor" & @CRLF & _
"Esq. Esquire" & @CRLF & _
"Hon. Honerable" & @CRLF & _
"Jr. Junior" & @CRLF & _
"Mr. Mister" & @CRLF & _
"Mrs. Misses" & @CRLF & _
"Ms. Miss" & @CRLF & _
"Messrs. Misters" & @CRLF & _
"Mmes. Misseses" & @CRLF & _
"Msgr. Monsignor" & @CRLF & _
"Prof. Professor" & @CRLF & _
"Rev. Reverend" & @CRLF & _
"Rt. Honorable" & @CRLF & _
"Sr. Senior" & @CRLF & _
"St. Saint"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")