import re
regex = re.compile(r"[A-Z]([a-z]+). [A-z]+", flags=re.MULTILINE)
test_str = ("Dr. Doctor\n"
"Esq. Esquire\n"
"Hon. Honerable\n"
"Jr. Junior\n"
"Mr. Mister\n"
"Mrs. Misses\n"
"Ms. Miss\n"
"Messrs. Misters\n"
"Mmes. Misseses\n"
"Msgr. Monsignor\n"
"Prof. Professor\n"
"Rev. Reverend\n"
"Rt. Honorable\n"
"Sr. Senior\n"
"St. Saint")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")