// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Z]([a-z]+). [A-z]+").unwrap();
let string = "Dr. Doctor
Esq. Esquire
Hon. Honerable
Jr. Junior
Mr. Mister
Mrs. Misses
Ms. Miss
Messrs. Misters
Mmes. Misseses
Msgr. Monsignor
Prof. Professor
Rev. Reverend
Rt. Honorable
Sr. Senior
St. Saint";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}