re = /[A-Z]([a-z]+). [A-z]+/m
str = 'Dr. Doctor
Esq. Esquire
Hon. Honerable
Jr. Junior
Mr. Mister
Mrs. Misses
Ms. Miss
Messrs. Misters
Mmes. Misseses
Msgr. Monsignor
Prof. Professor
Rev. Reverend
Rt. Honorable
Sr. Senior
St. Saint'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end