$re = '/[A-Z]([a-z]+). [A-z]+/m';
$str = 'Dr. Doctor
Esq. Esquire
Hon. Honerable
Jr. Junior
Mr. Mister
Mrs. Misses
Ms. Miss
Messrs. Misters
Mmes. Misseses
Msgr. Monsignor
Prof. Professor
Rev. Reverend
Rt. Honorable
Sr. Senior
St. Saint';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);