const regex = /[A-Z]([a-z]+). [A-z]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z]([a-z]+). [A-z]+', 'gm')
const str = `Dr. Doctor
Esq. Esquire
Hon. Honerable
Jr. Junior
Mr. Mister
Mrs. Misses
Ms. Miss
Messrs. Misters
Mmes. Misseses
Msgr. Monsignor
Prof. Professor
Rev. Reverend
Rt. Honorable
Sr. Senior
St. Saint`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}