using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![/]$|[/?].*$)(.*\/[?](.*)$|.*\/$)";
string input = @"/
/?abc=123&id=50
google.com
google.com/
google.com#test?ab=cd&id=50
google.com?abc=123&id=50
google.com/?abc=123&id=50
google.com/foo
google.com/foo/
google.com/foo/?abc=123&id=50
google.com/foo/bar
google.com/foo/bar/
google.com/foo/bar?abc=123&id=50
google.com/foo/bar/?abc=123&id=50
http://localhost:3000/
http://localhost:3000/blog
http://localhost:3000/blog/
http://localhost:3000/blog?ab=cd
http://localhost:3000/blog/?ab=cd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}