use strict;
my $str = '/
/?abc=123&id=50
google.com
google.com/
google.com#test?ab=cd&id=50
google.com?abc=123&id=50
google.com/?abc=123&id=50
google.com/foo
google.com/foo/
google.com/foo/?abc=123&id=50
google.com/foo/bar
google.com/foo/bar/
google.com/foo/bar?abc=123&id=50
google.com/foo/bar/?abc=123&id=50
http://localhost:3000/
http://localhost:3000/blog
http://localhost:3000/blog/
http://localhost:3000/blog?ab=cd
http://localhost:3000/blog/?ab=cd';
my $regex = qr/^(?![/]$|[/?].*$)(.*\/[?](.*)$|.*\/$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}