# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?![/]$|[/?].*$)(.*\/[?](.*)$|.*\/$)"
test_str = ("/\n"
"/?abc=123&id=50\n"
"google.com\n"
"google.com/\n"
"google.com#test?ab=cd&id=50\n"
"google.com?abc=123&id=50\n"
"google.com/?abc=123&id=50\n"
"google.com/foo\n"
"google.com/foo/\n"
"google.com/foo/?abc=123&id=50\n"
"google.com/foo/bar\n"
"google.com/foo/bar/\n"
"google.com/foo/bar?abc=123&id=50\n"
"google.com/foo/bar/?abc=123&id=50\n\n"
"http://localhost:3000/\n"
"http://localhost:3000/blog\n"
"http://localhost:3000/blog/\n"
"http://localhost:3000/blog?ab=cd\n"
"http://localhost:3000/blog/?ab=cd")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.