const regex = /^(?![/]$|[/?].*$)(.*\/[?](.*)$|.*\/$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![\/]$|[\/?].*$)(.*\\\/[?](.*)$|.*\\\/$)', 'gm')
const str = `/
/?abc=123&id=50
google.com
google.com/
google.com#test?ab=cd&id=50
google.com?abc=123&id=50
google.com/?abc=123&id=50
google.com/foo
google.com/foo/
google.com/foo/?abc=123&id=50
google.com/foo/bar
google.com/foo/bar/
google.com/foo/bar?abc=123&id=50
google.com/foo/bar/?abc=123&id=50
http://localhost:3000/
http://localhost:3000/blog
http://localhost:3000/blog/
http://localhost:3000/blog?ab=cd
http://localhost:3000/blog/?ab=cd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}