import Foundation
let pattern = #"^(?![/]$|[/?].*$)(.*\/[?](.*)$|.*\/$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
/
/?abc=123&id=50
google.com
google.com/
google.com#test?ab=cd&id=50
google.com?abc=123&id=50
google.com/?abc=123&id=50
google.com/foo
google.com/foo/
google.com/foo/?abc=123&id=50
google.com/foo/bar
google.com/foo/bar/
google.com/foo/bar?abc=123&id=50
google.com/foo/bar/?abc=123&id=50
http://localhost:3000/
http://localhost:3000/blog
http://localhost:3000/blog/
http://localhost:3000/blog?ab=cd
http://localhost:3000/blog/?ab=cd
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)