import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![/]$|[/?].*$)(.*\\/[?](.*)$|.*\\/$)";
final String string = "/\n"
+ "/?abc=123&id=50\n"
+ "google.com\n"
+ "google.com/\n"
+ "google.com#test?ab=cd&id=50\n"
+ "google.com?abc=123&id=50\n"
+ "google.com/?abc=123&id=50\n"
+ "google.com/foo\n"
+ "google.com/foo/\n"
+ "google.com/foo/?abc=123&id=50\n"
+ "google.com/foo/bar\n"
+ "google.com/foo/bar/\n"
+ "google.com/foo/bar?abc=123&id=50\n"
+ "google.com/foo/bar/?abc=123&id=50\n\n"
+ "http://localhost:3000/\n"
+ "http://localhost:3000/blog\n"
+ "http://localhost:3000/blog/\n"
+ "http://localhost:3000/blog?ab=cd\n"
+ "http://localhost:3000/blog/?ab=cd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}