$re = '/^(?![/]$|[/?].*$)(.*\/[?](.*)$|.*\/$)/m';
$str = '/
/?abc=123&id=50
google.com
google.com/
google.com#test?ab=cd&id=50
google.com?abc=123&id=50
google.com/?abc=123&id=50
google.com/foo
google.com/foo/
google.com/foo/?abc=123&id=50
google.com/foo/bar
google.com/foo/bar/
google.com/foo/bar?abc=123&id=50
google.com/foo/bar/?abc=123&id=50
http://localhost:3000/
http://localhost:3000/blog
http://localhost:3000/blog/
http://localhost:3000/blog?ab=cd
http://localhost:3000/blog/?ab=cd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);