import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{3})\\s(\\d{3})\\s(\\d{3})\\s(\\d{3})\\s(\\d{3})\\s(\\d{3})\\s(\\d{3})\\s(\\d{3})$";
final String string = "021 023 025 026 030 031 032 032";
final String subst = "\\1\\20\\3\\4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}