re = /^(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})$/m
str = '021 023 025 026 030 031 032 032'
subst = '\\1\\20\\3\\4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result