// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})$").unwrap();
let string = "021 023 025 026 030 031 032 032";
let substitution = "\\1\\20\\3\\4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}