$re = '/^(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})$/m';
$str = '021 023 025 026 030 031 032 032';
$subst = "\1\20\3\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;