const regex = /^(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})\s(\d{3})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{3})\\s(\\d{3})\\s(\\d{3})\\s(\\d{3})\\s(\\d{3})\\s(\\d{3})\\s(\\d{3})\\s(\\d{3})$', 'gm')
const str = `021 023 025 026 030 031 032 032`;
const subst = `\1\20\3\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);