#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s*$"
Local $sString = "shyc " & @CRLF & _
"ccl" & @CRLF & _
"" & @CRLF & _
"Orfey" & @CRLF & _
"" & @CRLF & _
"Max Daetwyler de Mexico S.A. de C.V." & @CRLF & _
"Huhtamaki" & @CRLF & _
"Bin Iqbal Gravure Services " & @CRLF & _
"" & @CRLF & _
"PSik " & @CRLF & _
"Galas de Mexico S.A de C.V " & @CRLF & _
"p " & @CRLF & _
"123" & @CRLF & _
"Graphelectronic " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Ohio Gravure Tech " & @CRLF & _
"shyc " & @CRLF & _
"Area de comunicaciones " & @CRLF & _
"HELL Gravure Systems " & @CRLF & _
"" & @CRLF & _
"Private " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Hell Gravure Systems " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"PSik " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"SPH " & @CRLF & _
"" & @CRLF & _
"vesim " & @CRLF & _
"namju industry " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Psik " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"PRISMA SA " & @CRLF & _
"mphoto " & @CRLF & _
"psik " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")