import Foundation
let pattern = #"\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
shyc
ccl
Orfey
Max Daetwyler de Mexico S.A. de C.V.
Huhtamaki
Bin Iqbal Gravure Services
PSik
Galas de Mexico S.A de C.V
p
123
Graphelectronic
Ohio Gravure Tech
shyc
Area de comunicaciones
HELL Gravure Systems
Private
Hell Gravure Systems
PSik
SPH
vesim
namju industry
Psik
PRISMA SA
mphoto
psik
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)