import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*$";
final String string = "shyc \n"
+ "ccl\n\n"
+ "Orfey\n\n"
+ "Max Daetwyler de Mexico S.A. de C.V.\n"
+ "Huhtamaki\n"
+ "Bin Iqbal Gravure Services \n\n"
+ "PSik \n"
+ "Galas de Mexico S.A de C.V \n"
+ "p \n"
+ "123\n"
+ "Graphelectronic \n\n\n\n"
+ "Ohio Gravure Tech \n"
+ "shyc \n"
+ "Area de comunicaciones \n"
+ "HELL Gravure Systems \n\n"
+ "Private \n\n\n"
+ "Hell Gravure Systems \n\n\n"
+ "PSik \n\n\n"
+ "SPH \n\n"
+ "vesim \n"
+ "namju industry \n\n\n\n\n"
+ "Psik \n\n\n"
+ "PRISMA SA \n"
+ "mphoto \n"
+ "psik \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}