re = /\s*$/m
str = 'shyc
ccl
Orfey
Max Daetwyler de Mexico S.A. de C.V.
Huhtamaki
Bin Iqbal Gravure Services
PSik
Galas de Mexico S.A de C.V
p
123
Graphelectronic
Ohio Gravure Tech
shyc
Area de comunicaciones
HELL Gravure Systems
Private
Hell Gravure Systems
PSik
SPH
vesim
namju industry
Psik
PRISMA SA
mphoto
psik
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end