package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*$`)
var str = `shyc
ccl
Orfey
Max Daetwyler de Mexico S.A. de C.V.
Huhtamaki
Bin Iqbal Gravure Services
PSik
Galas de Mexico S.A de C.V
p
123
Graphelectronic
Ohio Gravure Tech
shyc
Area de comunicaciones
HELL Gravure Systems
Private
Hell Gravure Systems
PSik
SPH
vesim
namju industry
Psik
PRISMA SA
mphoto
psik
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}