const regex = /\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*$', 'gm')
const str = `shyc
ccl
Orfey
Max Daetwyler de Mexico S.A. de C.V.
Huhtamaki
Bin Iqbal Gravure Services
PSik
Galas de Mexico S.A de C.V
p
123
Graphelectronic
Ohio Gravure Tech
shyc
Area de comunicaciones
HELL Gravure Systems
Private
Hell Gravure Systems
PSik
SPH
vesim
namju industry
Psik
PRISMA SA
mphoto
psik
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}