$re = '/\s*$/m';
$str = 'shyc
ccl
Orfey
Max Daetwyler de Mexico S.A. de C.V.
Huhtamaki
Bin Iqbal Gravure Services
PSik
Galas de Mexico S.A de C.V
p
123
Graphelectronic
Ohio Gravure Tech
shyc
Area de comunicaciones
HELL Gravure Systems
Private
Hell Gravure Systems
PSik
SPH
vesim
namju industry
Psik
PRISMA SA
mphoto
psik
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);