#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?miu)([0-9]{1,2})\s*([\u0400-\u04FF]+)\s*([0-9]{4}|[0-9]{2})|([0-9]{1,2})\s*(j|f|m|a|j|s|o|n|d[a-z.]+)\s*([0-9]{4}|[0-9]{2})|([0-9]{1,2})\s*[./]{1}\s*([0-9]{1,2})\s*[./]{1}\s*([0-9]{4}|[0-9]{2})"
Local $sString = "14ДекабрЯ 2017, 20: 05, вопрос № 1846141, г. Омск" & @CRLF & _
"Ответ 3 dec.97, 20: 05, вопрос № 1846141, г. Омск" & @CRLF & _
"Дата написания 15 марта 2011, 15:02 а следующая дата 23 . 06. 19"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")