using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]{1,2})\s*([\u0400-\u04FF]+)\s*([0-9]{4}|[0-9]{2})|([0-9]{1,2})\s*(j|f|m|a|j|s|o|n|d[a-z.]+)\s*([0-9]{4}|[0-9]{2})|([0-9]{1,2})\s*[./]{1}\s*([0-9]{1,2})\s*[./]{1}\s*([0-9]{4}|[0-9]{2})";
string input = @"14ДекабрЯ 2017, 20: 05, вопрос № 1846141, г. Омск
Ответ 3 dec.97, 20: 05, вопрос № 1846141, г. Омск
Дата написания 15 марта 2011, 15:02 а следующая дата 23 . 06. 19";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}