import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]{1,2})\\s*([\\u0400-\\u04FF]+)\\s*([0-9]{4}|[0-9]{2})|([0-9]{1,2})\\s*(j|f|m|a|j|s|o|n|d[a-z.]+)\\s*([0-9]{4}|[0-9]{2})|([0-9]{1,2})\\s*[./]{1}\\s*([0-9]{1,2})\\s*[./]{1}\\s*([0-9]{4}|[0-9]{2})";
final String string = "14ДекабрЯ 2017, 20: 05, вопрос № 1846141, г. Омск\n"
+ "Ответ 3 dec.97, 20: 05, вопрос № 1846141, г. Омск\n"
+ "Дата написания 15 марта 2011, 15:02 а следующая дата 23 . 06. 19";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}