import re
regex = re.compile(r"([0-9]{1,2})\s*([\u0400-\u04FF]+)\s*([0-9]{4}|[0-9]{2})|([0-9]{1,2})\s*(j|f|m|a|j|s|o|n|d[a-z.]+)\s*([0-9]{4}|[0-9]{2})|([0-9]{1,2})\s*[./]{1}\s*([0-9]{1,2})\s*[./]{1}\s*([0-9]{4}|[0-9]{2})", flags=re.MULTILINE | re.IGNORECASE | re.UNICODE)
test_str = ("14ДекабрЯ 2017, 20: 05, вопрос № 1846141, г. Омск\n"
"Ответ 3 dec.97, 20: 05, вопрос № 1846141, г. Омск\n"
"Дата написания 15 марта 2011, 15:02 а следующая дата 23 . 06. 19")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")