use strict;
my $str = '14ДекабрЯ 2017, 20: 05, вопрос № 1846141, г. Омск
Ответ 3 dec.97, 20: 05, вопрос № 1846141, г. Омск
Дата написания 15 марта 2011, 15:02 а следующая дата 23 . 06. 19';
my $regex = qr/([0-9]{1,2})\s*([\u0400-\u04FF]+)\s*([0-9]{4}|[0-9]{2})|([0-9]{1,2})\s*(j|f|m|a|j|s|o|n|d[a-z.]+)\s*([0-9]{4}|[0-9]{2})|([0-9]{1,2})\s*[./]{1}\s*([0-9]{1,2})\s*[./]{1}\s*([0-9]{4}|[0-9]{2})/miup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}