const regex = new RegExp('([0-9]{1,2})\\s*([\\u0400-\\u04FF]+)\\s*([0-9]{4}|[0-9]{2})|([0-9]{1,2})\\s*(j|f|m|a|j|s|o|n|d[a-z.]+)\\s*([0-9]{4}|[0-9]{2})|([0-9]{1,2})\\s*[./]{1}\\s*([0-9]{1,2})\\s*[./]{1}\\s*([0-9]{4}|[0-9]{2})', 'gmiu')
const str = `14ДекабрЯ 2017, 20: 05, вопрос № 1846141, г. Омск
Ответ 3 dec.97, 20: 05, вопрос № 1846141, г. Омск
Дата написания 15 марта 2011, 15:02 а следующая дата 23 . 06. 19`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}