package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b(?:north|south)(?:\h*(?:east|west))?\b|\b(?:east|west|[NS][WE]?|[EW])\b`)
var str = `SHOULD MATCH:
405 W 1st Street South west #910
North, South, West, East, North East, North West, South East, South West
N, S, NW, NE, SE, SW, E, W.
northeast northwest southeast southwest
PARTIAL MATCH:
north-west north-east south-west south-east
SHOULD NOT MATCH:
westnorth westsouth eastnorth eastsouth
wn ws en es
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}