use strict;
my $str = 'SHOULD MATCH:
405 W 1st Street South west #910
North, South, West, East, North East, North West, South East, South West
N, S, NW, NE, SE, SW, E, W.
northeast northwest southeast southwest
PARTIAL MATCH:
north-west north-east south-west south-east
SHOULD NOT MATCH:
westnorth westsouth eastnorth eastsouth
wn ws en es
';
my $regex = qr/\b(?:north|south)(?:\h*(?:east|west))?\b|\b(?:east|west|[NS][WE]?|[EW])\b/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}