// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\b(?:north|south)(?:\h*(?:east|west))?\b|\b(?:east|west|[NS][WE]?|[EW])\b").unwrap();
let string = "SHOULD MATCH:
405 W 1st Street South west #910
North, South, West, East, North East, North West, South East, South West
N, S, NW, NE, SE, SW, E, W.
northeast northwest southeast southwest
PARTIAL MATCH:
north-west north-east south-west south-east
SHOULD NOT MATCH:
westnorth westsouth eastnorth eastsouth
wn ws en es
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}