# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?:north|south)(?:\h*(?:east|west))?\b|\b(?:east|west|[NS][WE]?|[EW])\b"
test_str = ("SHOULD MATCH:\n"
"405 W 1st Street South west #910\n"
"North, South, West, East, North East, North West, South East, South West\n"
" N, S, NW, NE, SE, SW, E, W.\n"
"northeast northwest southeast southwest\n\n\n"
"PARTIAL MATCH:\n"
"north-west north-east south-west south-east\n\n\n"
"SHOULD NOT MATCH:\n"
"westnorth westsouth eastnorth eastsouth\n"
"wn ws en es\n\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.