import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:north|south)(?:\\h*(?:east|west))?\\b|\\b(?:east|west|[NS][WE]?|[EW])\\b";
final String string = "SHOULD MATCH:\n"
+ "405 W 1st Street South west #910\n"
+ "North, South, West, East, North East, North West, South East, South West\n"
+ " N, S, NW, NE, SE, SW, E, W.\n"
+ "northeast northwest southeast southwest\n\n\n"
+ "PARTIAL MATCH:\n"
+ "north-west north-east south-west south-east\n\n\n"
+ "SHOULD NOT MATCH:\n"
+ "westnorth westsouth eastnorth eastsouth\n"
+ "wn ws en es\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}