re = /\b(?:north|south)(?:\h*(?:east|west))?\b|\b(?:east|west|[NS][WE]?|[EW])\b/i
str = 'SHOULD MATCH:
405 W 1st Street South west #910
North, South, West, East, North East, North West, South East, South West
N, S, NW, NE, SE, SW, E, W.
northeast northwest southeast southwest
PARTIAL MATCH:
north-west north-east south-west south-east
SHOULD NOT MATCH:
westnorth westsouth eastnorth eastsouth
wn ws en es
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end