using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(....AA........CC............BB..)";
string input = @"215484320702AAFF155777CCFF9101101132BB4E00A0AACCCCCCCCCCCCCCF0111009BB850702AAFF155777CCFF9101101010BBXX
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}