package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(....AA........CC............BB..)`)
var str = `215484320702AAFF155777CCFF9101101132BB4E00A0AACCCCCCCCCCCCCCF0111009BB850702AAFF155777CCFF9101101010BBXX
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}