import Foundation
let pattern = #"(....AA........CC............BB..)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
215484320702AAFF155777CCFF9101101132BB4E00A0AACCCCCCCCCCCCCCF0111009BB850702AAFF155777CCFF9101101010BBXX
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}