$re = '/(....AA........CC............BB..)/';
$str = '215484320702AAFF155777CCFF9101101132BB4E00A0AACCCCCCCCCCCCCCF0111009BB850702AAFF155777CCFF9101101010BBXX
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);